Printer Friendly

An empirical study of mobility support in nested mobile networks.

INTRODUCTION

Many networking devices, communication gadgets and wireless services flourish. So the users need the internet connection on the move at any time. Today the users have many wireless gadgets, like laptops, Personal Digital Assistants (PDAs) and mobile phones. These devices can make a link with each other through their network interfaces, which forms a Personal Area Network (PAN).A PAN can also communicate with the internet backbone on the move through the Access Router (AR).A PAN is an example of a small scale mobile network, whereas a network that is deployed in the public transportation system such as in aero plane, bus or in train is an example for large scale mobile networks. If a smaller network is contained in a larger network, it is known as nested mobile networks.

The IETF has developed the protocols like Mobile IPv4 (MIPv4) and Mobile IPv6 (MIPv6) for providing the ubiquitous communication to the mobile network nodes on the move. These protocols support the host mobility but fail to support the network mobility. So the IETF proposed the protocol NEMO Basic Support which provides the network mobility support for the Mobile networks and Nested mobile networks.

A. Mobility Support:

1. Host Mobility support:

Host mobility support is used to maintain session continuity between Mobile Network Nodes (MNNs) and their Correspondent Nodes (CNs), when MNN's changes its point of attachment. Mobile IPV6 provides the solution for the Host Mobility support mechanisms.

2. Network mobility support:

Network mobility support is a means to maintain session continuity between Mobile Network Nodes (MNNs) and their Correspondent Nodes (CNs), when the Mobile Router (MR) dynamically changes its point of attachment. Solution for the network mobility support is provided by NEMO Basic Support and NEMO Extended Support. NEMO Basic Support standardized by IETF provides the solution to maintain the session continuity by establishing the bidirectional tunnel between MRs and their HAs. NEMO Extended support provides performance optimization like route optimization between arbitrary MNNs and CNs.

However the NEMO protocol has some performance limits like route optimization, and operational complexities while involving nested mobile networks. The main objective of the research work is analyzing the strengths and weakness of the existing works on the mobility support in nested mobile networks. The rest of the paper is organized as follows: Sec. II describes the architecture of Mobile network and Nested Mobile network and describes the pinball routing with a scenario. Sec. III briefly describes the related study of the current NEMO support protocols, and the contributions of IETF. It analyses and compares the strength and the weakness of the existing protocols. Sec. IV proposes a solution to avoid the pinball routing and Binding Update storm, which will reduce the handoff latency and hence decreases the packet loss rate during the message transit on the move. Finally, a concluding note is included in Sec. IV.

Architecture:

A. Mobile Network:

A mobile network is a subnet which moves as a single unit and is formed by one or more Mobile Routers (MR) and Mobile Network Nodes (MNNs). The MR has two interfaces namely egress and ingress interfaces. The egress interface connects the MR to the internet; the ingress interface connects the MR to the MNNs in the network. The MR changes its point of attachment to provide ubiquitous communication to MNNs within the network on the move. NEMO Basic Support proposed by IETF provides the mobility support when the mobile network changes its point of attachment on the internet.

Fig 1 shows the NEMO Basic support operations during the network mobility in a simple Mobile network. First the Mobile Router(MR) broadcasts the Router Advertisement (RA) message and in turn the MNN's receives the RA Message and configures its address. The packet transfer from the CN to the MNN in the mobile network and vice versa are made via MR. Then the MR performs the handoff procedure when the network moves. Here the MR alone will be aware of the movement of the network, and thus the MNNs are unaware of the movement of the network. All the MRs must have its own Home Agent (HA).

When a network changes its point of attachment to the internet, first, the MR acquires the Care of Address (CoA) from the foreign agent. The MR then updates its HA with its mobile network prefix and CoA which is called Prefix Scope Binding Update (PSBU).The MR in turn receives the Binding acknowledgement from its HA. Secondly, MR establishes a bidirectional tunnel between it's HA and itself to maintain the session continuity on the move. Fig 1 shows the Basic operations of NEMO.

B. Nested Mobile Network:

Personal Area Network (PAN) connected to the internet is an example of a simple mobile network. Furthermore, PANs in a mobile network (inside a vehicle) is an example of nested mobile network. The smaller mobile Network (sub NEMO) contained within a larger mobile network (parent NEMO) is said to be the Nested mobile Network. The smaller network together with the larger network becomes a single Nested mobile network. The aggregate hierarchy is as shown in the Fig. 2. It shows a Nested Mobile network with three levels in hierarchy of mobile routers.

When a MNN sends a message to a CN, it must pass through all its higher level MRs. in the Nested Mobile Network. When a message reaches a MR a tunnel has to be established with it's HA

The packets have to travel through the various MR-HA tunnels for a single message transmission. As the Mobile network moves the MR has to inform the new location to its Home Agent. This Binding Update (BU), its corresponding Binding Acknowledgement (BAck) and messages have to travel through these tunnels. This problem is called pin ball routing, which can be illustrated by the following scenario.

When a CN wishes to communicate with MNN3. The following actions occur

Step 1. CN sends the message to Mobile Network Node 3's Home Agent (HA3).

Step 2. MNN3-HA encapsulates and sends it to Mobile Router 3's HA (HA-MR3).

Step 3. HA-MR3 encapsulates and sends it to Home Agent of MR2 (HA -MR2).

Step 4. HA -MR2encpsulates and sends it to MR1-HA.

Step 5. MR1-HA encapsulates and sends it to Mobile Router1(MR1).

Step 6. MR1 sends it to MR2.

Step 7. MR2 sends it to MR3.

Step 8. MR3 sends it to Mobile Network Node3(MNN3).

C. Effects of pin ball routing in nested mobile network:

1. Increased packet overhead:

An extra IPv6 header is encapsulated to all the packets at each level of nesting. Since the source and destination are at different hop header compression cannot be applied. An increase in the number of levels of nesting increases the packet overhead.

2. Increased processing delay:

The multiple encapsulation and decapsulation of packets at the MR-HA tunnel leads to the increased processing delay.

3. Occurrence of packet fragmentation:

The expansion of packet size due to the encapsulation may lead to the packet fragmentation in the MR-HA tunnel [6].All these effects may increase the handoff latency, which leads to packet loss in the nested mobile network.

Literature review:

An efficient route will reduce the handoff latency, which in turn reduces the packet loss during the data transmission.

A. Contributions of IETF:

The NEMO Basic support protocol (Devrapalli, 2005) was proposed by IETF to support Network Mobility.

Besides that, IETF has made several RFCs to analyze the features, requirements and problems of NEMO Basic Support. The work done by these RFC's are highlighted below.

* RFC 4885 Network mobility support Terminology (Ernst, 2004) describes the architecture of Nested mobile network and the terminologies associated with the Nested mobile Network. It also investigates the issues and the solution requirements.

* RFC 4886 Network Mobility support goals and Requirements (Ernst, 2007) define the goals of NEMO Basic support and describe the required outcomes of the protocol.

* RFC 4887 Network Mobility home Network Models (Thubert, 2007) documents some of the usage patterns and issues, associated with it when deploying a home network for network Mobility (NEMO)-enabled Mobile Routers. This draft provides the examples of organization of the Home Network,

* RFC 4888 NEMO Route Optimization problem statement (Ng, 2007) explores the sub optimization routing problem while establishing the Bidirectional tunnel between the MR and it's HA. It investigates the performance in mobile networks and also in Nested mobile networks.

* RFC 4889 Network Mobility Route Optimization Solution Space Analysis (Thubert, 2007) As all the communication to and fro from the MNNs must go through the MR and its corresponding HA tunnel results in the complex route and packet delay. To overcome these limitations this draft provides the various route optimization techniques and investigates its benefits and tradeoffs.

* RFC 5177 NEMO Extensions for IPv4 (Leung, 2008) provides the mobility support to the entire mobile network by extending the Mobile IPv4. It addresses the co-located Care of Address mode while the MR is registering its location with its HA.

* RFC 5488 Network Mobility Management Information Base NEMO MIB (Gundavelli, 2009) defines the Network Mobility (NEMO) support MIB, for use with network management protocols in the Internet community. The NEMO MIB is used to monitor and control a Mobile IPv6 Node with NEMO functionality.

B. Analysis of existing protocols:

Thubert et al, proposed a solution for pinball routing problem (Thubert, 2007) with the new routing header called Reverse Routing Header (RRH) which circumvents the nested tunnel over head. It keeps an account of the routes out of the Nested Mobile Network, which is made as the routing header for the packets that are destined to this mobile network. It only requires constructing a bidirectional tunnel between the MNN's serving MR and its Home Agent (MR-HA) and hence resolves the pin ball routing which in turn avoids the nested tunnel overhead. RRH increases the packet overhead due to the introduction of the routing header for the packets.

Ng et al, proposed Access Router Option (ARO) (Ng, 2004) which is similar to the route optimization mechanism of MIPv6. Here the HA's of the MRs gather the binding information from their higher level MR's and the route optimization is done in a step by step manner which results in the long convergence time, which is proportional to the number of levels of nesting.

Yousaf et al., proposed (NERON) (Yousaf, Faqir Zarrar, 2009) an efficient protocol which resolves the pin ball routing by using an optimized communication path. Here when a mobile network (PAN), enters the another mobile network, first it has to detect and connect to the root MR(rMR) as nested MR(nMR).The process leads to router overhead, and an end to end delay during the message transit. It does not support intra nest communication between two MNNs in the same domain. Table I shows a comparative study of the existing mobility support protocols. Moreover, as the number of levels of nesting in Mobile Networks increases, these limitations become more complex. This document explores such problems and provides an impetus at the back of Route Optimization (RO) for NEMO.

Conclusion:

Today many portable devices that are being internet enabled, need the entire networks to be mobile. NEMO Extended support in an extension of NEMO Basic support protocol, which makes the mobile routers to act as a mobility agent on behalf of the entite network of portable IP devices. Many researches have been done to solve the limitations in Nested Mobility. The research presented some of the works done on the Nested Mobility in Mobile Networks and evaluated their advantages and weakness to provide an enhanced mobility support that can supplement the existing protocols.

ARTICLE INFO

Article history:

Received 12 October 2014

Received in revised form 26 December 2014

Accepted 1 January 2015

Available online 25 February 2015

REFERENCES

Devrapalli, V., 2005. "Network Mobility (NEMO) Basic Support Protocol", IETF, RFC 3963.

Ernst, T. and H. Lach, 2004. "Network Mobility Support Terminology", IETF, RFC 4885.

Ernst, T., 2007. Network mobility support goals and requirements. IETF, RFC 4886.

Gundavelli, S., G. Keeni, K. Koide and K. Nagami, 2009. Network mobility (NEMO) management information base. IETF, RFC 5488.

Leung, K., G. Dommety, V. Narayanan and A. Petrescu, 2008. "Network mobility (NEMO) extensions for mobile IPv4", IETF, RFC 5177.

Ng, C. and J. Hirano, 2004. "Securing Nested Tunnels optimization with access router option", Internet draft.

Ng, C., 2007. "Network Mobility Route Optimization Problem Statement", IETF, RFC 4888.

Thubert, P., 2007. "IPv6 Reverse Routing Header and its Applications to Mobile Networks" IETF Internet Draft, Febraury.

Thubert, P., 2007. "Network Mobility home Network Models", IETF, RFC 4887.

Thubert, P., 2007. "Network Mobility Route Optimization Solution Space Analysis", IETF, RFC 4889.

Yousaf, Faqir Zarrar, Alain Tigyo, and Christian Wietfeld, 2009. "NERON: a Route Optimization scheme for Nested Mobile Networks." Proceedings of the Wireless Communications and Networking Conference, IEEE, pp: 1-6.

(1) V. Sangeetha and (2) Dr. P. Calduwel Newton

(1) Asst Prof and Head, Department of Computer Science, Deen College of Arts and Science, Mayiladuthrai

(2) Department of Computer Science, Bishop Heber College, Trichy

Corresponding Author: V. Sangeetha, Asst Prof & Head, Department of Computer Science, Deen College of Arts and Science, Mayiladuthrai

E-mail: gv_gita@yahoo.co.in

Table I: Comparitive study of existing nemo support protocols

                          Comparison

Network                 Characteristics                Strength
Mobility Support
Protocol

NEMO BSP           Bi-directional tunneling       Preserves location
                                                       privacy

RRH                 MIP Route Optimization       Reduces the pinball
                                                       routing

ARO                 MIPv6 RouteOptimization    Reduces Packet overhead

NERON                  Uses Unsolicited        Resolves pinball routing
                    Neighbor Advertisement      and hence reduces the
                         (UNA) message            convergence time.

                            Comparison

Network                      Weakness
Mobility Support
Protocol

NEMO BSP                  Pinball routing

RRH                Packet overhead and BU storm

ARO                    Long convergence time

NERON               Does not support intra nest
                     communication between two
                     MNN's in the same domain.
COPYRIGHT 2015 American-Eurasian Network for Scientific Information
No portion of this article can be reproduced without the express written permission from the copyright holder.
Copyright 2015 Gale, Cengage Learning. All rights reserved.

Article Details
Printer friendly Cite/link Email Feedback
Author:Sangeetha, V.; Newton, P. Calduwel
Publication:Advances in Natural and Applied Sciences
Article Type:Report
Date:Jun 1, 2015
Words:2273
Previous Article:Clustering of job applications using ART network.
Next Article:Privacy protection in personalized web search.
Topics:

Terms of use | Privacy policy | Copyright © 2026 Farlex, Inc. | Feedback | For webmasters |